What are the minimum requirements?


Windows

Windows 7 and later are supported, older operating systems are not supported (and do not work).
Please note, the ARM version of Windows is not supported for now.

Mac

OS X 10.9 and later


Can't find your answer? Drop us a line

Featured on
Betalist